New Deployment - Version R20250527-prod-20250604-6b3376bb8e13b794645245af6fcd22f0f78168e7

Incident Report for 360X

Resolved

The new release has been successfully deployed.
Posted Jun 04, 2025 - 13:19 UTC

Investigating

We are deploying a new update to our environment. The service may be temporarily affected.
Posted Jun 04, 2025 - 13:14 UTC